
The DowntownVASSAL Interface. 
By Antonio Pinar. 
 
Introduction. 
The Main Interface is the core of the VASSAL engine; from here you can perform lots of 
actions like loading an online game, starting a new online game, or launch the PBeM. 
 
But as a first step let’s see what is and how is designed the Downtown Main Interface. 
 

 
 
This is the Downtown Main Interface, It is divided in several windows and switches. The 
biggest window is the Chat window. The chat window is divided in two blocks; one of 
them shows the traffic sent to the server by the players, the other is where the player write 
the words to form a message to be uploaded to the server. 
 
The great white space in the middle of the interface is the Chat Window where the 
player can read the messages sent by the system and players linked with the server. In the 
image above the message shown is – Downtown version 01. Under the main chat window 
is located a thin window, this is the Chat Line Window where the player can write his 
messages to upload to the chat server. 
 
Above the main chat window there is a stripe with several switches, this is the Control 
Panel. The player can perform several actions switching on/off these switches. This panel 
will be explained later in this write. 
 
Above the Control Panel is located the Game Panel. This panel ise common to all the 
VASSAL modules and contains only two keys; File and Help. Clicking on either key a 
specific menu will be launched; the File Menu clicking File, and the Help Menu clicking 
Help. 
 
Many switches are not available to the player at a specific time, you can reckon this 
switches (or options) easily, the one not highlighted is not available to the player at this 



time. In our example interface window above the US Force Pool for example is not 
available to the player at this time. 
 
The Game Panel. 
As mentioned two Keys are available; the File and the Help key. Each key has their own 
menu associated to it, in such a way that clicking either key will launch their distinctive 
menu. 
 
The File Menu: 

 
 
This is the File Menu; from this menu you can launch a new game, load a previously 
saved game, edit your own preferences… etc. Note there are some options not available 
to the player at this time, loading a game or launching a new game will change their 
availability status. 
 
The Help Menu: 

 
 



This is the Help Menu, this menu provides instant help to the player. As can be seen, 
there are three options and all of them available to the player, depending the help the 
player is looking, one or another may be launched. 
 
Control Panel. 
Under the Game Panel is the Control Panel, this window provides full control over all 
game features. Each switch performs a different action necessary to play Downtown, and 
as you can imagine, this window is specific for Downtown. 
 
The PBeM navigation Switches. 

When you are playing a PBeM game, selecting this switch, you 
can undo the last move loaded. As you can see, all switches have 
an explanatory pop up text associated to it. 
 
 

This switch will perform a step forward in the loaded logfile. This 
switch is only for PBeM games, and clicking on it will execute the 
next step (or move) contained into the loaded logfile. 
 

Both switches can be used as a whole, performing steps forward and steps backward as 
player desire. They are used with PBeM games, however the Undo switch can be used 
with any game loaded. 
 
Going Online Switch. 

This switch will launch a new window to connect to the internet 
allowing players to play online. Clicking this switch, the system will 
launch the Server Control window, this window has its own switches 
and windows, this window will be treated later. 
 

 
Board Switches. 

This switch will launch a new window, the US Force Pool 
board. This switch is available only to the US Player, and only 
when a game is loaded. The DRV Player will not be able to 
open this window, keeping the US Plans secured. 
 

This switch will launch the DRV AF Pool board. This switch is 
available only to the DRV Player, and only when a game is loaded. 
The US Player will not be able to open this window keeping the 
DRV plans secured. 

 
This switch will launch the Initiative Pool board. This switch is 
available to both players, but each player is able to handle his 
own deck. 
 

 



Pieces Switch. 

 
Dice Switches.

This switch will open a new window in witch the player has 
available counters and markers. Take note some counters and 
markers are available only to the owner player. 
 

 

 

Clicking this switch the system will simulate the launch of a ten sided 
die. This die roll is also launched pushing the key <F1> on the 
keyboard such as indicated in the pop up text. The resulted die roll will 
be shown in the Chat window. 

Clicking this switch the system will simulate the launch of a set of two 
ten sided die. This die roll can be read as either, the sum of both dice 
or as a percentile die roll. This die roll is also launched pushing the key 
<F2> on the keyboard. The value rolled will be shown in the chat 

window as two numeric values, one for each die. 
 
Chat Interface. 
As mentioned before, the chat interface is subdivided in two independent windows, the 
Main Chat window and the Chat line window. The chat interface is designed to allow 
players communications between them, also shows system notifications. 
 
Main Chat Window. 

 
 
This is the Main Chat window, this interface allows players to communicate between 
them. This window will show all messages sent over the server by the own player or by 
other players. Also, this window is used by the system to communicate with the players, 
reporting game issues like counter and marker movements, new counters and markers 
created by players, die rolls, initiative chits draw… etc. This window will notify players 
when the system is connected to a server, reporting also the version of the game being 
used. 



Chat Line Window. 

 
 

This is the Chat Line window, this interface allows the player to send messages to other 
Players connected to the server. To send a message to the server, the player will write the 
desired phrase pushing the key <ENTER> to validate the message, after a few seconds 
the message will be displayed in the Main Chat window along with the nickname adopted 
by the player. 
 
Creating a new Game. 
Now you will be instructed in how to create a new game. It is assumed you are familiar 
with the Main Interface. It is supposed the Main Interface is displayed in your desktop. 
 
1. Click the File key to launch the File Menu. 
2. In the File Menu select the option New Game. A new window will appear at this 

time, asking you about what side you want to play with, select the desired side and 
press the key <OK>. The Map board will be loaded at this time, and all switches 
become available. 

 
Now you are ready to play… vs. yourself! 
If you want to play vs. an opponent, there are two ways to go from here; Face to Face via 
online, or PBeM. 
 
Going PBeM: 
Let’s simulate we are creating a PBeM game, because the online connection is better with 
no game loaded in the interface. 
 
To go PBeM launch the File Menu again, with a game loaded you have to see a File 
Menu like this: 

Now select the option Begin Logfile from the File 
Menu. From this time all your actions will be recorded 
by the system. Note however, you have all the options 
available except the one called End Logfile. The 
option End Logfile will become available once you 
have selected the option Begin Logfile. As you are a 
smart guy, at this time you have extracted that this 
End Logfile option is used to finish your Player turn 
(or whatever you are doing!), saving all these recorded 
moves and messages posted. 
 
Once pushed the End Logfile option a new window 
will appear asking you about the location and the 
name where to grab the new Logfile. 

 



At this time, you can write a fine warning message to your opponent and emailing the 
message and the logfile to your opponent. 
 
There is another unknown option available, Load Continuation. This option is used 
when you are playing a PBeM game to upload the logfiles your opponent is sending you 
in response yours. 
 
Going Online. 
The more challenger way to play Downtown (aside the real one face to face) is going 
online: the virtual face to face. Now you will be instructed in how to go online, and play 
games online. It is supposed you have not game loaded and the main interface is 
displayed in your desktop. Also it is supposed you are familiar with the Main Interface. 
 
1. Click the Going Online switch to launch the Server Control window. 
2. Once the Server Control window is launched, press the key to connect to the server. 
 

 
 

This is the Server Control window, here you can see some new switches and two new 
windows called Active Games and Current Game, and also there is a little window into 
the Active Games window called New Game. 
 
The switch to connect to the server is the first key on the left hand, next (not available 
yet) is the key to exit from the server. Remainder keys are used to show the player status 
to the rest of the room, and finally the keys to upload and read mails hanged on the 
server. Still there are a last key, the one with an interrogation sign, it is used to explore 
who are playing modules using VASSAL. 
 
The two windows are used to show who are connected to the server and using the 
Downtown Module. The window Active Games will show all rooms created where 
players are running games. The window Current Game will show who is connected to 
the room highlighted in the Active Games window. The little window into the Active 
Games window and called New Game, it is used to create a new room where to run a 
new game. 



The Game Interface. 
Once a game is loaded, new windows and switches will be added to the Main Interface. 
This is the display that appears once a game is loaded: 
 

 
 

As can be seen, a whole new window will appears under the Chat Line Window; the Map 
Board window. Also new switches will be added to the ones already existing. 
 
The new switches are used to handle the map board window and to provide new features 
to the player status. The Retire switch is used to allow the player to leave their sit, 
allowing new players to take the just vacated sit. 
 
The Map Board Switches. 

These are the Map Board Switches. The first 
switch with a camera image is used to take an 
instant image of the map. The next switch is 
used to hide or show the map board window. 
The Thread switch is used to take a line 
between two given points over the map, 
providing the distance in hexes between both 

points. Next are two switches to provide Zoom capabilities to the map. Finally the last 
switch is used to delete the “moved” labels that receive the moved flights. 
 
The VASSAL Server. 
The VASSAL engine uses a private server maintained and supported by Rodney Kinney 
with the only purpose to support the gamer’s community. This server is used every time a 
player connects to the internet using the VASSAL engine. Players using the same 



VASSAL Module will be able to see each others, but those using a different VASSAL 
Module will not be seen. In other words, players have to be using the same Module to 
play between them, or observe other games. The server can be busied with lots of games 
from a wide variety of Modules in play, but players are aware of them using the same 
Module. 
 
This server is supported by a machine acting as a host, and as always, machines are 
affected by several problems that can put them out of order. When this problem happens, 
the server simply hangs out and become out of order. In support to this problem, there is 
a backup server that assumes responsibility and if things go worsen, still a final step; the 
application then launch an interface allowing connections between own players using the 
machine of either player as the new host. 
 
Game Pieces. 
Counters and Markers are termed as Game Pieces, and so available into the counter tray 
window. To launch this window, the player has to click on the Pieces switch. The 
counters and markers contained into this Counter Tray Window are the ones used to 
move and place over the Map Board Window. The DRV and the US force Pool contains 
their own set of pieces, but this pieces can be used ONLY into the own Pool. There is 
another Pool available, the Initiative Pool, pieces belonging to this last Pool must to be 
placed over the Map Board in order to work properly, this is the ONLY exception that 
allows pieces belonging to a Pool Board to be set up over the Map Board Window. 

 
This is the Counter Tray Window; here the player has all the counters and markers 
necessary to play Downtown available. This window uses the principle “click and drag” 
to CREATE playing pieces over the Map Board Window. 

 
The Counter Tray Window is designed in 
that a way that players always know where 
to find a given counter or marker.  
 
All US Units are contained into the US 
Forces folder, so all US flights are available 
into this folder. The same can be said for the 
DRV Forces folder. The DRV Player has to 
go to the DRV Forces folder to find all his 
flights and ground counters. Markers can be 
found in the Markers folder. 
Every folder is organized in that a way that 

a given player can find the desired specific counter (or Marker) easily. 
 
The image above shows the Marker folder with the Basic Markers subfolder shown on 
the tray window. To draw a marker from the tray window, the player has to click and 
drag the desired counter to its destination hex or new location. The Marker folder is 
subdivided in several subfolders, the one shown is the Basic Subfolder. 

 



 
 
This is the US Forces folder, as can be seen it is subdivided in three more subfolders, and 
them subdivided again in several subfolders more. This design is useful to easy find 
where is located a specific counter. Again, to draw an US Flight from the tray window, 
the player has to click and drag the desired flight to its destination hex or new location. 
 

 
 

This is the DRV Forces folder, as occurred with the US Forces folder; it is subdivided in 
several subfolders.  
 
Characteristics. 
Counters and Markers are doted with specific characteristics depending the type of unit it 

, right clicking over the counter or marker, a menu 
window will be displayed from the counter (marker) 
with all the options applicable to that counter listed 
on it. 

is representing. As a common rule

The image shows the option menu specific for this 
counter, a US Generic Flight. Selecting an option 
with the mouse pointer will perform the selected 
action for immediate. 
Note there is a shortcut key listed along the specific 
action available for that key. For example, the listed 
Option Flightlog can be launch in both ways, 



selecting it with the mouse pointer or simply typing the combined key <CTR + I>. 
 
The menu displayed in our example is common to all the Flight counters; other counter 
types use different menus.  
 
The more distinctive menu entries will be explained here below to help understanding. 
 
Flightlog (SAMlog). 
This is an optional feature. This feature simulates the Flightlog (SAMlog) for the selected 
Flight (SAM) Counter. All fields contained in the paper version sheet are implemented 
here, so if a player wants to play avoiding using the paper sheet has to use this feature 
instead. 
 
Text. 
This is another optional feature, here the system puts a text field in the players hands 
where to point comments that are visible to all players. This field can be useful to take 
note about issues like throttle settings, selected speed, aborting flights… etc. 
 
Rotate. 
Flights must rotate in order to change heading, here the system allows the player to 
change course with a mouse click or simply by typing the shortcut key. 
 
Mark Moved. 
The system take account of flights moved (flights are considered moved when they 
change their map location, not their facing). Using this option, the player can voluntarily 
change this status. 
 
Flip. 
Many counters and markers are double sided pieces; the player can voluntarily change 
the side representing the game piece. 
 
Clone and Delete. 
The gaming pieces can be freely deleted once their use is not longer necessary, the fact to 
clone a game piece is not recommended, players should avoid cloning game pieces.  
 
Property Setting. 
In order to preserve some counter’s features secured from the “indiscrete” opponent’s 
eyes, some game pieces were provided with an ownership pattern. This last feature 
provides the necessary “fog of war” with the which the game was designed. There are 
some game pieces (and boards) which have given a specific owner player, only the owner 
player has free access to those game pieces (and boards). 
 
This property setting cannot be changed during a game, nor even at start of the game; the 
module has been built based on property setting patterns. 
 



Still there is a last issue here. The game was designed allowing a Player playing solo, in 
that a way that when a game is launched as a solo game, the solitaire Player has free 
access to all counters, markers and boards. 
 
Pools and Boards.
The module has been designed based in three Pools and one Board, the Map Board.  
The Map Board is where the game takes action. All game pieces placed on the map 
comes from the Counter Tray Window and so fully visible for both players; the DRV and 
USA (also for observers, if any), the only exception to this rule, as explained before, is 
for the pieces coming from the Initiative Pool. 
 
As mentioned before, Pools are owned by specific players. The DRV AF Pool is owned 
by the DRV Player and only the DRV Player has fully access to this board, the same is 
said for the USA Player and the US Force Pool. In fact, players without ownership cannot 
even launch the Pool not under his hands. Finally as occurred with counters and markers, 
Pools can be freely accessed by a solitaire Player. 
 

 



This is the DRV AF Pool, here the DRV Player can plan his air game aside the 
opponent’s eyes. In this board, the DRV Player has available all his flight counters, 
Generic and Visually Sighted. Unlike the Counter Tray Window, the counters provided 
within the Pools are available in a limited account, within the limits given in the original 
counter mix provided with the Gamebox. 
 
Ending.
Well folks, till here was given the necessary instruction to start playing Downtown using 
the VASSAL engine. Still there is pending some more features and tips, but this work is 
left to your own experimentation impulse. 
 
Also I expect all you that are reading this posting will be able to understanding me well, 
at least that was my first intention here. 
 
Yours, 
Antonio Pinar. 
Madrid. 
Spain. 


